Elizabeth Clarke eclarke at
Mon Jun 5 23:53:57 EST 2000

"Banks, Kelly" wrote:
> I was hitting the exact same error & wound up tracking it into the
> libtermcap.2.0.8 that I was using...  Mine went away when I used the termcap
> available from Mvista.

Hmmm, didn't make any difference. But then I dont understand what
difference it could make. AIUI anything compiled with egcs ie the JDK
binaries are incompatible with anything compiled with gcc  - my
libraries, because egcs
referenced the symbol register_frame_info. I tried making a library with
just that symbol and pre-loading it, but still got the error:

/usr/jre118-v2/bin/ppc/green_threads/jre: error in loading shared
libraries: /usr/jre118-v2/lib/ppc/green_threads/ symbol
__register_frame_info, version GLIBC_2.0 not defined in file
with link time reference

I think I'm going to have to investigate the JDK-1.2.2 and glibc-2.1.3
Franz Sirl's site, unless I'm missing something completely?...


** Sent via the linuxppc-embedded mail list. See

More information about the Linuxppc-embedded mailing list