[PATCH][next] powerpc/ps3: replace open-coded sysfs_emit function
Geoff Levand
geoff at infradead.org
Mon Oct 21 19:49:49 AEDT 2024
Hi Paulo,
On 10/19/24 11:13, Paulo Miguel Almeida wrote:
> sysfs_emit() helper function should be used when formatting the value
> to be returned to user space.
>
> This patch replaces open-coded sysfs_emit() in sysfs .show() callbacks
>
> Link: https://github.com/KSPP/linux/issues/105
> Signed-off-by: Paulo Miguel Almeida <paulo.miguel.almeida.rodenas at gmail.com>
> ---
> arch/powerpc/platforms/ps3/system-bus.c | 5 ++---
> 1 file changed, 2 insertions(+), 3 deletions(-)
>
> diff --git a/arch/powerpc/platforms/ps3/system-bus.c b/arch/powerpc/platforms/ps3/system-bus.c
> index b9a7d9bae687..afbaabf182d0 100644
> --- a/arch/powerpc/platforms/ps3/system-bus.c
> +++ b/arch/powerpc/platforms/ps3/system-bus.c
> @@ -453,10 +453,9 @@ static ssize_t modalias_show(struct device *_dev, struct device_attribute *a,
> char *buf)
> {
> struct ps3_system_bus_device *dev = ps3_dev_to_system_bus_dev(_dev);
> - int len = snprintf(buf, PAGE_SIZE, "ps3:%d:%d\n", dev->match_id,
> - dev->match_sub_id);
>
> - return (len >= PAGE_SIZE) ? (PAGE_SIZE - 1) : len;
> + return sysfs_emit(buf, "ps3:%d:%d\n", dev->match_id,
> + dev->match_sub_id);
> }
> static DEVICE_ATTR_RO(modalias);
I tested this on PS3 and it seems to work OK.
Thanks for your contribution.
Acked-by: Geoff Levand <geoff at infradead.org>
More information about the Linuxppc-dev
mailing list