[PATCH v2] mm/memblock: Add memblock_alloc_or_panic interface
Weikang Guo
guoweikang.kernel at gmail.com
Sun Dec 22 11:52:14 AEDT 2024
Geert Uytterhoeven <geert at linux-m68k.org> wrote on Saturday, 21
December 2024 at 22:10
>
> Hi Guo,
>
> On Sat, Dec 21, 2024 at 11:43 AM Guo Weikang
> <guoweikang.kernel at gmail.com> wrote:
> > Before SLUB initialization, various subsystems used memblock_alloc to
> > allocate memory. In most cases, when memory allocation fails, an immediate
> > panic is required. To simplify this behavior and reduce repetitive checks,
> > introduce `memblock_alloc_or_panic`. This function ensures that memory
> > allocation failures result in a panic automatically, improving code
> > readability and consistency across subsystems that require this behavior.
> >
> > Signed-off-by: Guo Weikang <guoweikang.kernel at gmail.com>
>
> Thanks for your patch!
>
> > --- a/include/linux/memblock.h
> > +++ b/include/linux/memblock.h
> > @@ -417,6 +417,20 @@ static __always_inline void *memblock_alloc(phys_addr_t size, phys_addr_t align)
> > MEMBLOCK_ALLOC_ACCESSIBLE, NUMA_NO_NODE);
> > }
> >
> > +static __always_inline void *__memblock_alloc_or_panic(phys_addr_t size,
> > + phys_addr_t align,
> > + const char *func)
> > +{
> > + void *addr = memblock_alloc(size, align);
> > +
> > + if (unlikely(!addr))
> > + panic("%s: Failed to allocate %llu bytes\n", func, size);
> > + return addr;
> > +}
>
> Please make this out-of-line, and move it to mm/memblock.c, so we have
> just a single copy in the final binary.
>
Got it, I'll make the change
> > +
> > +#define memblock_alloc_or_panic(size, align) \
> > + __memblock_alloc_or_panic(size, align, __func__)
> > +
> > static inline void *memblock_alloc_raw(phys_addr_t size,
> > phys_addr_t align)
> > {
> > diff --git a/init/main.c b/init/main.c
>
> Gr{oetje,eeting}s,
>
> Geert
>
> --
> Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert at linux-m68k.org
>
> In personal conversations with technical people, I call myself a hacker. But
> when I'm talking to journalists I just say "programmer" or something like that.
> -- Linus Torvalds
Best regards
Guo
More information about the Linuxppc-dev
mailing list