[PATCH 0/2] Deduplicate bin_attribute simple read() callbacks
Lukas Wunner
lukas at wunner.de
Sun Apr 7 00:52:00 AEDT 2024
For my upcoming PCI device authentication v2 patches, I have the need
to expose a simple buffer in virtual memory as a bin_attribute.
It turns out we've duplicated the ->read() callback for such simple
buffers a fair number of times across the tree.
So instead of reinventing the wheel, I decided to introduce a common
helper and eliminate all duplications I could find.
I'm open to a bikeshedding discussion on the sysfs_bin_attr_simple_read()
name. ;)
Lukas Wunner (2):
sysfs: Add sysfs_bin_attr_simple_read() helper
treewide: Use sysfs_bin_attr_simple_read() helper
arch/powerpc/platforms/powernv/opal.c | 10 +-------
drivers/acpi/bgrt.c | 9 +-------
drivers/firmware/dmi_scan.c | 12 ++--------
drivers/firmware/efi/rci2-table.c | 10 +-------
drivers/gpu/drm/i915/gvt/firmware.c | 26 +++++----------------
.../intel/int340x_thermal/int3400_thermal.c | 9 +-------
fs/sysfs/file.c | 27 ++++++++++++++++++++++
include/linux/sysfs.h | 15 ++++++++++++
init/initramfs.c | 10 +-------
kernel/module/sysfs.c | 13 +----------
10 files changed, 56 insertions(+), 85 deletions(-)
--
2.43.0
More information about the Linuxppc-dev
mailing list