[PATCH 1/2] vmcore: allow alternate dump capturing methods to export vmcore without is_kdump_kernel()

Hari Bathini hbathini at linux.ibm.com
Wed Sep 6 05:25:54 AEST 2023

On 05/09/23 8:00 am, Baoquan He wrote:
> On 09/04/23 at 08:04pm, Hari Bathini wrote:
>> Hi Baoquan,
>> Thanks for the review...
>> On 03/09/23 9:06 am, Baoquan He wrote:
>>> Hi Hari,
>>> On 09/02/23 at 12:34am, Hari Bathini wrote:
>>>> Currently, is_kdump_kernel() returns true when elfcorehdr_addr is set.
>>>> While elfcorehdr_addr is set for kexec based kernel dump mechanism,
>>>> alternate dump capturing methods like fadump [1] also set it to export
>>>> the vmcore. is_kdump_kernel() is used to restrict resources in crash
>>>> dump capture kernel but such restrictions may not be desirable for
>>>> fadump. Allow is_kdump_kernel() to be defined differently for such
>>>> scenarios. With this, is_kdump_kernel() could be false while vmcore
>>>> is usable. So, introduce is_crashdump_kernel() to return true when
>>>> elfcorehdr_addr is set and use it for vmcore related checks.
>>> I got what is done in these two patches, but didn't get why they need be
>>> done. vmcore_unusable()/is_vmcore_usable() are only unitilized in ia64.
>>> Why do you care if it's is_crashdump_kernel() or is_kdump_kernel()?
>>> If you want to override the generic is_kdump_kernel() with powerpc's own
>>> is_kdump_kernel(), your below change is enough to allow you to do that.
>>> I can't see why is_crashdump_kernel() is needed. Could you explain that
>>> specifically?
>> You mean to just remove is_kdump_kernel() check in is_vmcore_usable() &
>> vmcore_unusable() functions? Replaced generic is_crashdump_kernel()
>> function instead, that returns true for any dump capturing method,
>> irrespective of whether is_kdump_kernel() returns true or false.
>> For fadump case, is_kdump_kernel() will return false after patch 2/2.
> OK, I could understand what you want to achieve. You want to make
> is_kdump_kernel() only return true for kdump, while is_vmcore_usable()
> returns true for both kdump and fadump.
> IIUC, can we change as below? It could make code clearer and more
> straightforward. I don't think adding another is_crashdump_kernel()
> is a good idea, that would be a torture for non-powerpc people reading
> code when they need differentiate between kdump and crashdump.

Sure, Baoquan.
Posted v2 based on your suggestion.


More information about the Linuxppc-dev mailing list