KUEP broken on FSP2?

Michael Ellerman mpe at ellerman.id.au
Tue Oct 10 22:03:18 AEDT 2023

Christophe Leroy <christophe.leroy at csgroup.eu> writes:
> Le 09/10/2023 à 17:12, Eddie James a écrit :
>> On 10/9/23 08:14, Michael Ellerman wrote:
>>> Eddie James <eajames at linux.ibm.com> writes:
>>>> Hi,
>>>> I'm attempting to run linux 6.1 on my FSP2, but my kernel crashes
>>>> attempting to get into userspace. The init script works, but the first
>>>> binary (mount) I run results in oops. Can anyone help me to debug this
>>>> further or suggest anything?
>>> Hi Eddie,
>>> It looks like breakage in syscall_exit_finish.
>>> Can you test this? Patch is against v6.1.
>> That worked! Perfect. Thank you very much! Will you send it upstream?
> Well spotted Michael. Looks like I messed it up with commit 6f76a01173cc 
> ("powerpc/syscall: implement system call entry/exit logic in C for PPC32")

I should have spotted it when applying ;)

That old asm code with all those unnamed labels was super fragile.

> Thanks for fixing.

No worries.


More information about the Linuxppc-dev mailing list