[PATCH v4 06/17] watchdog/perf: Rename watchdog_hld.c to watchdog_perf.c

Petr Mladek pmladek at suse.com
Thu May 11 20:09:24 AEST 2023

On Thu 2023-05-04 15:13:38, Douglas Anderson wrote:
> The code currently in "watchdog_hld.c" is for detecting hardlockups
> using perf, as evidenced by the line in the Makefile that only
> compiles this file if CONFIG_HARDLOCKUP_DETECTOR_PERF is
> defined. Rename the file to prepare for the buddy hardlockup detector,
> which doesn't use perf.
> It could be argued that the new name makes it less obvious that this
> is a hardlockup detector. While true, it's not hard to remember that
> the "perf" detector is always a hardlockup detector and it's nice not
> to have names that are too convoluted.
> Signed-off-by: Douglas Anderson <dianders at chromium.org>

Looks good:

Reviewed-by: Petr Mladek <pmladek at suse.com>

Best Regards,

More information about the Linuxppc-dev mailing list