[PATCH v4 11/17] watchdog/hardlockup: Rename some "NMI watchdog" constants/function

Nicholas Piggin npiggin at gmail.com
Fri May 5 13:06:41 AEST 2023

On Fri May 5, 2023 at 8:13 AM AEST, Douglas Anderson wrote:
> Do a search and replace of:
> - watchdog_nmi_ => watchdog_hardlockup_

These are just making prefixes inconsistent again.

If you really want to do a prefix, I would call it hardlockup which
probably best matches existing code and sysctl / boot stuff, and
concentrate on non-static symbols.

No problem with minor things like this that touch arch/powerpc
going through Andrew's tree though. I'm sure sparc maintainers
wouldn't mind either.


More information about the Linuxppc-dev mailing list