[PATCH v3 0/6] powerpc: merge _switch in 32/64

Nicholas Piggin npiggin at gmail.com
Tue Jun 6 23:24:41 AEST 2023


Since v2:
- Add PPC_CREATE_STACK_FRAME() to abstract prologue differences.
- Build fix.
- Makefile tidy [Christophe]
- Fix a missing SOB.

Since v1:
- Don't re-order 32-bit prologue.
- Improve Kconfig conditional includes.
- Break out code changes into their own patches before merging,
  so merge patch leaves generated code unchanged.
- Change prom_entry.S to prom_entry_64.S.


Nicholas Piggin (6):
  powerpc/64s: move stack SLB pinning out of line from _switch
  powerpc/64: Rearrange 64-bit _switch to prepare for 32/64 merge
  powerpc/32: Remove sync from _switch
  powerpc/32: Rearrange _switch to prepare for 32/64 merge
  powerpc: merge 32-bit and 64-bit _switch implementation
  powerpc/64: Rename entry_64.S to prom_entry_64.S

 arch/powerpc/include/asm/ppc_asm.h           |  14 +
 arch/powerpc/kernel/Makefile                 |  14 +-
 arch/powerpc/kernel/entry_32.S               |  58 ----
 arch/powerpc/kernel/prom_entry_64.S          |  87 +++++
 arch/powerpc/kernel/{entry_64.S => switch.S} | 331 ++++++++-----------
 scripts/head-object-list.txt                 |   2 +-
 6 files changed, 238 insertions(+), 268 deletions(-)
 create mode 100644 arch/powerpc/kernel/prom_entry_64.S
 rename arch/powerpc/kernel/{entry_64.S => switch.S} (59%)

-- 
2.40.1



More information about the Linuxppc-dev mailing list