[PATCH] arch/powerpc/include/asm/barrier.h: redefine rmb and wmb to lwsync

Christophe Leroy christophe.leroy at csgroup.eu
Wed Feb 22 18:02:34 AEDT 2023



Le 22/02/2023 à 07:01, Kautuk Consul a écrit :
> A link from ibm.com states:
> "Ensures that all instructions preceding the call to __lwsync
>   complete before any subsequent store instructions can be executed
>   on the processor that executed the function. Also, it ensures that
>   all load instructions preceding the call to __lwsync complete before
>   any subsequent load instructions can be executed on the processor
>   that executed the function. This allows you to synchronize between
>   multiple processors with minimal performance impact, as __lwsync
>   does not wait for confirmation from each processor."
> 
> Thats why smp_rmb() and smp_wmb() are defined to lwsync.
> But this same understanding applies to parallel pipeline
> execution on each PowerPC processor.
> So, use the lwsync instruction for rmb() and wmb() on the PPC
> architectures that support it.
> 
> Also removed some useless spaces.
> 
> Signed-off-by: Kautuk Consul <kconsul at linux.vnet.ibm.com>
> ---
>   arch/powerpc/include/asm/barrier.h | 12 +++++++++---
>   1 file changed, 9 insertions(+), 3 deletions(-)
> 
> diff --git a/arch/powerpc/include/asm/barrier.h b/arch/powerpc/include/asm/barrier.h
> index e80b2c0e9315..553f5a5d20bd 100644
> --- a/arch/powerpc/include/asm/barrier.h
> +++ b/arch/powerpc/include/asm/barrier.h
> @@ -41,11 +41,17 @@
>   
>   /* The sub-arch has lwsync */
>   #if defined(CONFIG_PPC64) || defined(CONFIG_PPC_E500MC)
> -#    define SMPWMB      LWSYNC

This line shouldn't be changed by your patch

> +#undef rmb
> +#undef wmb

I see no point with defining something and undefining them a few lines 
later.

Instead, why not do:

#define mb()   __asm__ __volatile__ ("sync" : : : "memory")

#if defined(CONFIG_PPC64) || defined(CONFIG_PPC_E500MC)
#define rmb()	({__asm__ __volatile__ ("lwsync" : : : "memory"); })
#define wmb()	({__asm__ __volatile__ ("lwsync" : : : "memory"); })
#else
#define rmb()  __asm__ __volatile__ ("sync" : : : "memory")
#define wmb()  __asm__ __volatile__ ("sync" : : : "memory")
#endif

By the way, why put it inside a ({ }) ?
And I think nowdays we use "asm volatile" not "__asm__ __volatile__"

Shouldn't you also consider the same for mb() ?

Note that your series will conflict with b6e259297a6b ("powerpc/kcsan: 
Memory barriers semantics") in powerpc/next tree.

> +/* Redefine rmb() to lwsync. */

WHat's the added value of this comment ? Isn't it obvious in the line 
below that rmb() is being defined to lwsync ? Please avoid useless comments.

> +#define rmb()	({__asm__ __volatile__ ("lwsync" : : : "memory"); })
> +/* Redefine wmb() to lwsync. */
> +#define wmb()	({__asm__ __volatile__ ("lwsync" : : : "memory"); })
> +#define SMPWMB      LWSYNC
>   #elif defined(CONFIG_BOOKE)
> -#    define SMPWMB      mbar

This line shouldn't be changed by your patch

> +#define SMPWMB      mbar
>   #else
> -#    define SMPWMB      eieio

This line shouldn't be changed by your patch

> +#define SMPWMB      eieio
>   #endif
>   
>   /* clang defines this macro for a builtin, which will not work with runtime patching */


More information about the Linuxppc-dev mailing list