[PATCH V7 13/20] riscv: compat: process: Add UXL_32 support in start_thread

Guo Ren guoren at kernel.org
Sat Mar 12 23:46:59 AEDT 2022


On Sat, Mar 12, 2022 at 4:36 PM Arnd Bergmann <arnd at arndb.de> wrote:
>
> On Sat, Mar 12, 2022 at 3:13 AM Guo Ren <guoren at kernel.org> wrote:
> > On Fri, Mar 11, 2022 at 9:38 PM Ben Dooks <ben.dooks at codethink.co.uk> wrote:
> > > On 11/03/2022 02:38, Guo Ren wrote:
> > > >> --- a/arch/riscv/kernel/process.c
> > > >> +++ b/arch/riscv/kernel/process.c
> > > >> @@ -97,6 +97,11 @@ void start_thread(struct pt_regs *regs, unsigned long pc,
> > > >>          }
> > > >>          regs->epc = pc;
> > > >>          regs->sp = sp;
> > > >> +
> > > > FIxup:
> > > >
> > > > + #ifdef CONFIG_COMPAT
> > > >> +       if (is_compat_task())
> > > >> +               regs->status = (regs->status & ~SR_UXL) | SR_UXL_32;
> > > >> +       else
> > > >> +               regs->status = (regs->status & ~SR_UXL) | SR_UXL_64;
> > > > + #endif
> > > >
> > > > We still need "#ifdef CONFIG_COMPAT" here, because for rv32 we can't
> > > > set SR_UXL at all. SR_UXL is BIT[32, 33].
> > >
> > > would an if (IS_ENABLED(CONFIG_COMPAT)) { } around the lot be better
> > > than an #ifdef here?
> >
> > I don't think, seems #ifdef CONFIG_COMPAT is more commonly used in arch/*
>
> We used to require an #ifdef check around is_compat_task(), so there are
> a lot of stale #ifdefs that could be removed. In general, 'if (IS_ENABLED())'
> is considered more readable than #ifdef inside of a function. In this case
> there are a number of better ways to write the function if you want to get
> into the details:
>
>  - firstly, you should remove the #ifdef check around the definition of
>    SR_UXL, otherwise the IS_ENABLED() check does not work.
>
>  - you can use an 'if (!IS_ENABLED(CONFIG_COMPAT)) \\ return;' ahead of the
>    assignment since that is at the end of  the function.
>
>  - you can remove the bit masking since 'regs->status' is initialized above it,
>    adding in only the one bit, shortening it to
>
>     if (IS_ENABLED(CONFIG_COMPAT))
>                regs->status |= is_compat_task()) ? SR_UXL_32 : SR_UXL_64;
>
>  - to make this more logical, I would suggest always assigning the SR_UXL
>    bits regardless of CONFIG_COMPAT, and instead make it something like
>
>   if (IS_ENABLED(CONFIG_32BIT) || is_compat_task())
>             regs->status = | SR_UXL_32;
>   else
>             regs->status = | SR_UXL_64;
When CONFIG_32BIT=y, regs->status is 32bit width but SR_UXL_32 is
34bit width. That's wrong in type. (Only CONFIG_64BIT has SR_UXL).

>
>        Arnd



-- 
Best Regards
 Guo Ren

ML: https://lore.kernel.org/linux-csky/


More information about the Linuxppc-dev mailing list