[PATCH v3 3/3] block: sed-opal: keyring support for SED keys
Greg Joyce
gjoyce at linux.vnet.ibm.com
Fri Dec 2 03:58:24 AEDT 2022
On Thu, 2022-12-01 at 11:12 -0500, Ben Boeckel wrote:
> On Thu, Dec 01, 2022 at 09:29:36 -0600, Greg Joyce wrote:
> > On Wed, 2022-11-30 at 22:46 -0500, Ben Boeckel wrote:
> > > Perhaps naming it `OPAL_MAX_KEY_LEN` would help clarify this?
> >
> > I'm not averse to changing it because it would be clearer. My
> > concern
> > is that it's been OPAL_KEY_MAX for 5+ years (the original SED Opal
> > commit). Unless there is strong consensus to change it, I'm going
> > to
> > leave it as the original name.
>
> I don't care about the name (very much in the peanut gallery), just
> it
> not being a magic number :) .
>
> --Ben
Now I get you! I think that you mean changing to this:
if (ret > 0) {
if (ret > sizeof(key->key_len)) {
ret = -ENOSPC;
goto error;
}
key->key_len = ret;
key->key_type = OPAL_INCLUDED;
}
More information about the Linuxppc-dev
mailing list