[PATCH 02/13] module: add a module_loaded helper
Christophe Leroy
christophe.leroy at csgroup.eu
Thu Jan 21 21:17:39 AEDT 2021
Le 21/01/2021 à 11:13, David Laight a écrit :
> From: Christophe Leroy
Sorry I hit "Reply to the list" instead of "Reply all"
Cc Christoph H. who is the author.
>> Sent: 21 January 2021 10:00
>>
>> Le 21/01/2021 à 08:49, Christoph Hellwig a écrit :
>>> Add a helper that takes modules_mutex and uses find_module to check if a
>>> given module is loaded. This provides a better abstraction for the two
>>> callers, and allows to unexport modules_mutex and find_module.
>>>
>>> Signed-off-by: Christoph Hellwig <hch at lst.de>
>>> ---
>>> drivers/gpu/drm/drm_fb_helper.c | 7 +------
>>> include/linux/module.h | 3 +++
>>> kernel/module.c | 14 ++++++++++++--
>>> kernel/trace/trace_kprobe.c | 4 +---
>>> 4 files changed, 17 insertions(+), 11 deletions(-)
>>>
>>
>>> diff --git a/include/linux/module.h b/include/linux/module.h
>>> index 7a0bcb5b1ffccd..b4654f8a408134 100644
>>> --- a/include/linux/module.h
>>> +++ b/include/linux/module.h
>>> @@ -589,6 +589,9 @@ static inline bool within_module(unsigned long addr, const struct module *mod)
>>> /* Search for module by name: must hold module_mutex. */
>>> struct module *find_module(const char *name);
>>>
>>> +/* Check if a module is loaded. */
>>> +bool module_loaded(const char *name);
>>
>> Maybe module_is_loaded() would be a better name.
>
> I can't see the original patch.
You have it there
https://patchwork.ozlabs.org/project/linuxppc-dev/patch/20210121074959.313333-3-hch@lst.de/
>
> What is the point of the function.
> By the time it returns the information is stale - so mostly useless.
>
> Surely you need to use try_module_get() instead?
>
> David
>
> -
> Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK
> Registration No: 1397386 (Wales)
>
More information about the Linuxppc-dev
mailing list