[PATCH 11/25] soc: fsl: qe: qe_common: Fix misnamed function attribute 'addr'
Lee Jones
lee.jones at linaro.org
Wed Nov 4 02:28:24 AEDT 2020
Fixes the following W=1 kernel build warning(s):
drivers/soc/fsl/qe/qe_common.c:237: warning: Function parameter or member 'addr' not described in 'cpm_muram_dma'
drivers/soc/fsl/qe/qe_common.c:237: warning: Excess function parameter 'offset' description in 'cpm_muram_dma'
Cc: Qiang Zhao <qiang.zhao at nxp.com>
Cc: Li Yang <leoyang.li at nxp.com>
Cc: Scott Wood <scottwood at freescale.com>
Cc: act <dmalek at jlc.net>
Cc: Dan Malek <dan at embeddedalley.com>
Cc: "Software, Inc" <source at mvista.com>
Cc: Vitaly Bordug <vbordug at ru.mvista.com>
Cc: linuxppc-dev at lists.ozlabs.org
Signed-off-by: Lee Jones <lee.jones at linaro.org>
---
drivers/soc/fsl/qe/qe_common.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/soc/fsl/qe/qe_common.c b/drivers/soc/fsl/qe/qe_common.c
index 75075591f6308..497a7e0fd0272 100644
--- a/drivers/soc/fsl/qe/qe_common.c
+++ b/drivers/soc/fsl/qe/qe_common.c
@@ -231,7 +231,7 @@ EXPORT_SYMBOL(cpm_muram_offset);
/**
* cpm_muram_dma - turn a muram virtual address into a DMA address
- * @offset: virtual address from cpm_muram_addr() to convert
+ * @addr: virtual address from cpm_muram_addr() to convert
*/
dma_addr_t cpm_muram_dma(void __iomem *addr)
{
--
2.25.1
More information about the Linuxppc-dev
mailing list