[PATCH 1/2] powerpc/irq: don't use current_stack_pointer() in check_stack_overflow()

Christophe Leroy christophe.leroy at c-s.fr
Fri Jan 24 17:19:57 AEDT 2020



Le 24/01/2020 à 06:46, Michael Ellerman a écrit :
> Christophe Leroy <christophe.leroy at c-s.fr> writes:
> 
>> current_stack_pointer() doesn't return the stack pointer, but the
>> caller's stack frame. See commit bfe9a2cfe91a ("powerpc: Reimplement
>> __get_SP() as a function not a define") and commit acf620ecf56c
>> ("powerpc: Rename __get_SP() to current_stack_pointer()") for details.
>>
>> The purpose of check_stack_overflow() is to verify that the stack has
>> not overflowed.
>>
>> To really know whether the stack pointer is still within boundaries,
>> the check must be done directly on the value of r1.
>>
>> Signed-off-by: Christophe Leroy <christophe.leroy at c-s.fr>
>> ---
>>   arch/powerpc/kernel/irq.c | 5 ++---
>>   1 file changed, 2 insertions(+), 3 deletions(-)
>>
>> diff --git a/arch/powerpc/kernel/irq.c b/arch/powerpc/kernel/irq.c
>> index bb34005ff9d2..4d468d835558 100644
>> --- a/arch/powerpc/kernel/irq.c
>> +++ b/arch/powerpc/kernel/irq.c
>> @@ -599,9 +599,8 @@ u64 arch_irq_stat_cpu(unsigned int cpu)
>>   static inline void check_stack_overflow(void)
>>   {
>>   #ifdef CONFIG_DEBUG_STACKOVERFLOW
>> -	long sp;
>> -
>> -	sp = current_stack_pointer() & (THREAD_SIZE-1);
>> +	register unsigned long r1 asm("r1");
>> +	long sp = r1 & (THREAD_SIZE - 1);
> 
> This appears to work but seems to be "unsupported" by GCC, and clang
> actually complains about it:
> 
>    /linux/arch/powerpc/kernel/irq.c:603:12: error: variable 'r1' is uninitialized when used here [-Werror,-Wuninitialized]
>            long sp = r1 & (THREAD_SIZE - 1);
>                      ^~
> 
> The GCC docs say:
> 
>    The only supported use for this feature is to specify registers for
>    input and output operands when calling Extended asm (see Extended
>    Asm).
> 
> https://gcc.gnu.org/onlinedocs/gcc-9.1.0/gcc/Local-Register-Variables.html#Local-Register-Variables
> 
> 
> If I do this it seems to work, but feels a little dicey:
> 
> 	asm ("" : "=r" (r1));
> 	sp = r1 & (THREAD_SIZE - 1);


Or we could do add in asm/reg.h what we have in boot/reg.h:

register void *__stack_pointer asm("r1");
#define get_sp()	(__stack_pointer)

And use get_sp()

I'll try it.

Christophe


More information about the Linuxppc-dev mailing list