[PATCH v1 05/10] powerpc/pseries/iommu: Add iommu_pseries_alloc_table() helper

Alexey Kardashevskiy aik at ozlabs.ru
Mon Aug 24 10:38:57 AEST 2020



On 18/08/2020 09:40, Leonardo Bras wrote:
> Creates a helper to allow allocating a new iommu_table without the need
> to reallocate the iommu_group.
> 
> This will be helpful for replacing the iommu_table for the new DMA window,
> after we remove the old one with iommu_tce_table_put().
> 
> Signed-off-by: Leonardo Bras <leobras.c at gmail.com>
> ---
>  arch/powerpc/platforms/pseries/iommu.c | 25 ++++++++++++++-----------
>  1 file changed, 14 insertions(+), 11 deletions(-)
> 
> diff --git a/arch/powerpc/platforms/pseries/iommu.c b/arch/powerpc/platforms/pseries/iommu.c
> index 8fe23b7dff3a..39617ce0ec83 100644
> --- a/arch/powerpc/platforms/pseries/iommu.c
> +++ b/arch/powerpc/platforms/pseries/iommu.c
> @@ -53,28 +53,31 @@ enum {
>  	DDW_EXT_QUERY_OUT_SIZE = 2
>  };
>  
> -static struct iommu_table_group *iommu_pseries_alloc_group(int node)
> +static struct iommu_table *iommu_pseries_alloc_table(int node)
>  {
> -	struct iommu_table_group *table_group;
>  	struct iommu_table *tbl;
>  
> -	table_group = kzalloc_node(sizeof(struct iommu_table_group), GFP_KERNEL,
> -			   node);
> -	if (!table_group)
> -		return NULL;
> -
>  	tbl = kzalloc_node(sizeof(struct iommu_table), GFP_KERNEL, node);
>  	if (!tbl)
> -		goto free_group;
> +		return NULL;
>  
>  	INIT_LIST_HEAD_RCU(&tbl->it_group_list);
>  	kref_init(&tbl->it_kref);
> +	return tbl;
> +}
>  
> -	table_group->tables[0] = tbl;
> +static struct iommu_table_group *iommu_pseries_alloc_group(int node)
> +{
> +	struct iommu_table_group *table_group;
> +
> +	table_group = kzalloc_node(sizeof(*table_group), GFP_KERNEL, node);


I'd prefer you did not make unrelated changes (sizeof(struct
iommu_table_group) -> sizeof(*table_group)) so the diff stays shorter
and easier to follow. You changed  sizeof(struct iommu_table_group) but
not sizeof(struct iommu_table) and this confused me enough to spend more
time than this straight forward change deserves.

Not important in this case though so

Reviewed-by: Alexey Kardashevskiy <aik at ozlabs.ru>




> +	if (!table_group)
> +		return NULL;
>  
> -	return table_group;
> +	table_group->tables[0] = iommu_pseries_alloc_table(node);
> +	if (table_group->tables[0])
> +		return table_group;
>  
> -free_group:
>  	kfree(table_group);
>  	return NULL;
>  }
> 

-- 
Alexey


More information about the Linuxppc-dev mailing list