[Very RFC 16/46] powernv/eeh: Use eeh_edev_warn() rather than open-coding a BDFN print

Alexey Kardashevskiy aik at ozlabs.ru
Fri Nov 22 17:17:27 AEDT 2019



On 20/11/2019 12:28, Oliver O'Halloran wrote:
> Neaten things up a bit and remove a pci_dn use.
> 
> Signed-off-by: Oliver O'Halloran <oohall at gmail.com>



Reviewed-by: Alexey Kardashevskiy <aik at ozlabs.ru>

but it also could be merged into some bigger patch, it is hardly useful
on its own.


> ---
>  arch/powerpc/platforms/powernv/eeh-powernv.c | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
> 
> diff --git a/arch/powerpc/platforms/powernv/eeh-powernv.c b/arch/powerpc/platforms/powernv/eeh-powernv.c
> index aaccb3768393..f58fe6bda46e 100644
> --- a/arch/powerpc/platforms/powernv/eeh-powernv.c
> +++ b/arch/powerpc/platforms/powernv/eeh-powernv.c
> @@ -1001,10 +1001,8 @@ static void pnv_eeh_wait_for_pending(struct eeh_dev *edev, const char *type,
>  		msleep((1 << i) * 100);
>  	}
>  
> -	pr_warn("%s: Pending transaction while issuing %sFLR to %04x:%02x:%02x.%01x\n",
> -		__func__, type,
> -		pdn->phb->global_number, pdn->busno,
> -		PCI_SLOT(pdn->devfn), PCI_FUNC(pdn->devfn));
> +	eeh_edev_warn(edev, "%s: Pending transaction while issuing %sFLR\n",
> +		__func__, type);
>  }
>  
>  static int pnv_eeh_do_flr(struct eeh_dev *edev, int option)
> 

-- 
Alexey


More information about the Linuxppc-dev mailing list