[PATCH] dma-mapping: treat dev->bus_dma_mask as a DMA limit
Robin Murphy
robin.murphy at arm.com
Thu Nov 14 07:34:15 AEDT 2019
On 13/11/2019 4:13 pm, Nicolas Saenz Julienne wrote:
> Using a mask to represent bus DMA constraints has a set of limitations.
> The biggest one being it can only hold a power of two (minus one). The
> DMA mapping code is already aware of this and treats dev->bus_dma_mask
> as a limit. This quirk is already used by some architectures although
> still rare.
>
> With the introduction of the Raspberry Pi 4 we've found a new contender
> for the use of bus DMA limits, as its PCIe bus can only address the
> lower 3GB of memory (of a total of 4GB). This is impossible to represent
> with a mask. To make things worse the device-tree code rounds non power
> of two bus DMA limits to the next power of two, which is unacceptable in
> this case.
>
> In the light of this, rename dev->bus_dma_mask to dev->bus_dma_limit all
> over the tree and treat it as such. Note that dev->bus_dma_limit is
> meant to contain the higher accesible DMA address.
Neat, you win a "why didn't I do it that way in the first place?" :)
Looking at it without all the history of previous attempts, this looks
entirely reasonable, and definitely a step in the right direction.
[...]
> diff --git a/drivers/acpi/arm64/iort.c b/drivers/acpi/arm64/iort.c
> index 5a7551d060f2..f18827cf96df 100644
> --- a/drivers/acpi/arm64/iort.c
> +++ b/drivers/acpi/arm64/iort.c
> @@ -1097,7 +1097,7 @@ void iort_dma_setup(struct device *dev, u64 *dma_addr, u64 *dma_size)
> * Limit coherent and dma mask based on size
> * retrieved from firmware.
> */
> - dev->bus_dma_mask = mask;
> + dev->bus_dma_limit = mask;
Although this preserves the existing behaviour, as in of_dma_configure()
we can do better here since we have the original address range to hand.
I think it's worth keeping the ACPI and OF paths in sync for minor
tweaks like this, rather than letting them diverge unnecessarily.
Otherwise, the rest looks OK to me - in principle we could store it as
an exclusive limit such that we could then streamline the min_not_zero()
tests to just min(mask, limit - 1), but that's probably too clever for
its own good.
Robin.
> dev->coherent_dma_mask = mask;
> *dev->dma_mask = mask;
> }
More information about the Linuxppc-dev
mailing list