[PATCH] mm/nvdimm: Use correct #defines instead of opencoding
Elliott, Robert (Servers)
elliott at hpe.com
Wed May 22 00:49:47 AEST 2019
> -----Original Message-----
> From: Linux-nvdimm <linux-nvdimm-bounces at lists.01.org> On Behalf Of
> Aneesh Kumar K.V
> Sent: Tuesday, May 21, 2019 4:51 AM
> Subject: Re: [PATCH] mm/nvdimm: Use correct #defines instead of
> opencoding
>
...
> @@ -36,6 +36,9 @@ struct nd_pfn_sb {
> __le32 end_trunc;
> /* minor-version-2 record the base alignment of the mapping */
> __le32 align;
> + /* minor-version-3 record the page size and struct page size
> */
> + __le32 page_size;
> + __le32 page_struct_size;
> u8 padding[4000];
> __le64 checksum;
> };
You might need to reduce the padding size to offset the extra added
fields.
More information about the Linuxppc-dev
mailing list