[PATCH 2/3] powerpc/module32: Use symbolic instructions names.

Christophe Leroy christophe.leroy at c-s.fr
Thu May 2 17:24:37 AEST 2019



Le 29/04/2019 à 13:54, Segher Boessenkool a écrit :
> On Mon, Apr 29, 2019 at 10:43:27AM +0000, Christophe Leroy wrote:
>> To increase readability/maintainability, replace hard coded
>> instructions values by symbolic names.
> 
>> +	/* lis r12,sym at ha */
>> +#define ENTRY_JMP0(sym)	(PPC_INST_ADDIS | __PPC_RT(R12) | PPC_HA(sym))
>> +	/* addi r12,r12,sym at l */
>> +#define ENTRY_JMP1(sym)	(PPC_INST_ADDI | __PPC_RT(R12) | __PPC_RA(R12) | PPC_LO(sym))
> 
> Those aren't "jump" instructions though, as the name suggests...  And you
> only have names for the first two of the four insns.  ("2" and "3" were
> still available ;-) )

Well, the idea was to say they are defining the jump destination.
Anyway, as they are used only once, let's put it directly in.

> 
>> -	entry->jump[0] = 0x3d800000+((val+0x8000)>>16); /* lis r12,sym at ha */
>> -	entry->jump[1] = 0x398c0000 + (val&0xffff);     /* addi r12,r12,sym at l*/
>> -	entry->jump[2] = 0x7d8903a6;                    /* mtctr r12 */
>> -	entry->jump[3] = 0x4e800420;			/* bctr */
>> +	entry->jump[0] = ENTRY_JMP0(val);
>> +	entry->jump[1] = ENTRY_JMP1(val);
>> +	entry->jump[2] = PPC_INST_MTCTR | __PPC_RS(R12);
>> +	entry->jump[3] = PPC_INST_BCTR;
> 
> Deleting the comment here is not an improvement imo.

Ok, I'll leave them in as I did for module64

Christophe

> 
> 
> Segher
> 


More information about the Linuxppc-dev mailing list