ppc64le: ftrace self-tests and $(CC_FLAGS_FTRACE) broken?

Joe Lawrence joe.lawrence at redhat.com
Tue Mar 26 03:07:17 AEDT 2019

On 3/23/19 1:27 PM, Joe Lawrence wrote:
> On 03/23/2019 12:17 PM, Steven Rostedt wrote:
>> On Sat, 23 Mar 2019 09:19:50 -0400
>> Joe Lawrence <joe.lawrence at redhat.com> wrote:
>>> Perhaps this is gcc version specific?  I didn't see any other reports,
>>> so maybe its specific to my config.  If I run make V=1, I can see that
>>> gcc is called with '-pg -mprofile-kernel', but then the record_mcount
>>> script is skipped.  Any ideas?
>> But you see it running the script if you remove that commit? Do you
>> happen to see -mrecord-mcount at all in a V=1 make?
> See entire make output from the two runs here:
> http://people.redhat.com/~jolawren/ppc64le-mprofile/

Mystery solved!  That other commit inadvertently added a trailing space 
to CC_FLAGS_FTRACE, which then confused the findstring call in the 
cmd_record_mcount Makefile function.

Workaround patch just posted ... kbuild experts can suggest better fixes 
if that one is sub optimal.


-- Joe

More information about the Linuxppc-dev mailing list