[PATCH] treewide: Rename rcu_dereference_raw_notrace to _check

Joel Fernandes joel at joelfernandes.org
Fri Jul 12 06:50:26 AEST 2019

On Thu, Jul 11, 2019 at 4:45 PM Joel Fernandes (Google)
<joel at joelfernandes.org> wrote:
> The rcu_dereference_raw_notrace() API name is confusing.
> It is equivalent to rcu_dereference_raw() except that it also does
> sparse pointer checking.
> There are only a few users of rcu_dereference_raw_notrace(). This
> patches renames all of them to be rcu_dereference_raw_check with the
> "check" indicating sparse checking.
> Signed-off-by: Joel Fernandes (Google) <joel at joelfernandes.org>

There also these _notrace things but I am Ok with leaving them alone for now:

- Joel

More information about the Linuxppc-dev mailing list