[PATCH v2 2/2] powerpc: use probe_user_read()
Christophe Leroy
christophe.leroy at c-s.fr
Tue Jan 8 20:19:31 AEDT 2019
Le 08/01/2019 à 10:04, David Hildenbrand a écrit :
> On 08.01.19 08:37, Christophe Leroy wrote:
>> Instead of opencoding, use probe_user_read() to failessly
>> read a user location.
>>
>> Signed-off-by: Christophe Leroy <christophe.leroy at c-s.fr>
>> ---
>> v2: Using probe_user_read() instead of probe_user_address()
>>
>> arch/powerpc/kernel/process.c | 12 +-----------
>> arch/powerpc/mm/fault.c | 6 +-----
>> arch/powerpc/perf/callchain.c | 20 +++-----------------
>> arch/powerpc/perf/core-book3s.c | 8 +-------
>> arch/powerpc/sysdev/fsl_pci.c | 10 ++++------
>> 5 files changed, 10 insertions(+), 46 deletions(-)
>>
[snip]
>> diff --git a/arch/powerpc/sysdev/fsl_pci.c b/arch/powerpc/sysdev/fsl_pci.c
>> index 918be816b097..c8a1b26489f5 100644
>> --- a/arch/powerpc/sysdev/fsl_pci.c
>> +++ b/arch/powerpc/sysdev/fsl_pci.c
>> @@ -1068,13 +1068,11 @@ int fsl_pci_mcheck_exception(struct pt_regs *regs)
>> addr += mfspr(SPRN_MCAR);
>>
>> if (is_in_pci_mem_space(addr)) {
>> - if (user_mode(regs)) {
>> - pagefault_disable();
>> - ret = get_user(inst, (__u32 __user *)regs->nip);
>> - pagefault_enable();
>> - } else {
>> + if (user_mode(regs))
>> + ret = probe_user_read(&inst, (void __user *)regs->nip,
>> + sizeof(inst));
>
> What about also adding probe_user_address ?
Michael doesn't like it, see https://patchwork.ozlabs.org/patch/1007117/
Christophe
>
>> + else
>> ret = probe_kernel_address((void *)regs->nip, inst);
>> - }
>>
>> if (!ret && mcheck_handle_load(regs, inst)) {
>> regs->nip += 4;
>>
>
>
More information about the Linuxppc-dev
mailing list