[PATCH v5 5/7] powerpc/mm: Write to PTCR only if ultravisor disabled
Michael Ellerman
mpe at ellerman.id.au
Wed Aug 14 22:04:49 AEST 2019
Claudio Carvalho <cclaudio at linux.ibm.com> writes:
> In ultravisor enabled systems, PTCR becomes ultravisor privileged only
> for writing and an attempt to write to it will cause a Hypervisor
> Emulation Assitance interrupt.
>
> This patch adds the try_set_ptcr(val) macro as an accessor to
> mtspr(SPRN_PTCR, val), which will be executed only if ultravisor
> disabled.
>
> Signed-off-by: Claudio Carvalho <cclaudio at linux.ibm.com>
> ---
> arch/powerpc/include/asm/reg.h | 13 +++++++++++++
> arch/powerpc/mm/book3s64/hash_utils.c | 4 ++--
> arch/powerpc/mm/book3s64/pgtable.c | 2 +-
> arch/powerpc/mm/book3s64/radix_pgtable.c | 6 +++---
> 4 files changed, 19 insertions(+), 6 deletions(-)
>
> diff --git a/arch/powerpc/include/asm/reg.h b/arch/powerpc/include/asm/reg.h
> index 10caa145f98b..14139b1ebdb8 100644
> --- a/arch/powerpc/include/asm/reg.h
> +++ b/arch/powerpc/include/asm/reg.h
> @@ -15,6 +15,7 @@
> #include <asm/cputable.h>
> #include <asm/asm-const.h>
> #include <asm/feature-fixups.h>
> +#include <asm/firmware.h>
reg.h is already too big and unwieldy.
Can you put this in ultravisor.h and include that in the appropriate places.
> @@ -1452,6 +1453,18 @@ static inline void update_power8_hid0(unsigned long hid0)
> */
> asm volatile("sync; mtspr %0,%1; isync":: "i"(SPRN_HID0), "r"(hid0));
> }
> +
> +/*
> + * In ultravisor enabled systems, PTCR becomes ultravisor privileged only for
> + * writing and an attempt to write to it will cause a Hypervisor Emulation
> + * Assistance interrupt.
> + */
> +#define try_set_ptcr(val) \
> + do { \
> + if (!firmware_has_feature(FW_FEATURE_ULTRAVISOR)) \
> + mtspr(SPRN_PTCR, val); \
> + } while (0)
This should be a static inline please, not a macro.
Sorry, I don't like the name, we're not trying to set it, we know when
to set it and when not to.
It is awkward to come up with a good name because we don't have a term
for "hypervisor that's not running under an ultravisor".
Maybe set_ptcr_when_no_uv()
Which is kinda messy, someone feel free to come up with something
better.
I also see some more accesses to the PTCR in
arch/powerpc/platforms/powernv/idle.c which you haven't patched?
cheers
More information about the Linuxppc-dev
mailing list