[PATCH v2 5/9] powerpc/eeh: Rename frozen_bus to bus in eeh_handle_normal_event()

Alexey Kardashevskiy aik at ozlabs.ru
Wed Mar 21 16:18:19 AEDT 2018


On 19/3/18 1:47 pm, Sam Bobroff wrote:
> The name "frozen_bus" is misleading: it's not necessarily frozen, it's
> just the PE's PCI bus.
> 
> Signed-off-by: Sam Bobroff <sam.bobroff at au1.ibm.com>

Reviewed-by: Alexey Kardashevskiy <aik at ozlabs.ru>


> ---
>  arch/powerpc/kernel/eeh_driver.c | 10 +++++-----
>  1 file changed, 5 insertions(+), 5 deletions(-)
> 
> diff --git a/arch/powerpc/kernel/eeh_driver.c b/arch/powerpc/kernel/eeh_driver.c
> index 04a5d9db5499..cb584d72b0a5 100644
> --- a/arch/powerpc/kernel/eeh_driver.c
> +++ b/arch/powerpc/kernel/eeh_driver.c
> @@ -754,14 +754,14 @@ static int eeh_reset_device(struct eeh_pe *pe, struct pci_bus *bus,
>   */
>  void eeh_handle_normal_event(struct eeh_pe *pe)
>  {
> -	struct pci_bus *frozen_bus;
> +	struct pci_bus *bus;
>  	struct eeh_dev *edev, *tmp;
>  	int rc = 0;
>  	enum pci_ers_result result = PCI_ERS_RESULT_NONE;
>  	struct eeh_rmv_data rmv_data = {LIST_HEAD_INIT(rmv_data.edev_list), 0};
>  
> -	frozen_bus = eeh_pe_bus_get(pe);
> -	if (!frozen_bus) {
> +	bus = eeh_pe_bus_get(pe);
> +	if (!bus) {
>  		pr_err("%s: Cannot find PCI bus for PHB#%x-PE#%x\n",
>  			__func__, pe->phb->global_number, pe->addr);
>  		return;
> @@ -820,7 +820,7 @@ void eeh_handle_normal_event(struct eeh_pe *pe)
>  	 */
>  	if (result == PCI_ERS_RESULT_NONE) {
>  		pr_info("EEH: Reset with hotplug activity\n");
> -		rc = eeh_reset_device(pe, frozen_bus, NULL);
> +		rc = eeh_reset_device(pe, bus, NULL);
>  		if (rc) {
>  			pr_warn("%s: Unable to reset, err=%d\n",
>  				__func__, rc);
> @@ -938,7 +938,7 @@ void eeh_handle_normal_event(struct eeh_pe *pe)
>  		eeh_pe_dev_mode_mark(pe, EEH_DEV_REMOVED);
>  
>  		pci_lock_rescan_remove();
> -		pci_hp_remove_devices(frozen_bus);
> +		pci_hp_remove_devices(bus);
>  		pci_unlock_rescan_remove();
>  		/* The passed PE should no longer be used */
>  		return;
> 


-- 
Alexey


More information about the Linuxppc-dev mailing list