[PATCH v2 0/9] EEH refactoring 1
Alexey Kardashevskiy
aik at ozlabs.ru
Wed Mar 21 16:16:25 AEDT 2018
On 19/3/18 1:45 pm, Sam Bobroff wrote:
> Hello everyone,
>
> Here is a set of some small, mostly idempotent, changes to improve
> maintainability in some of the EEH code, primarily in eeh_driver.c.
>
> I've kept them all small to aid review but perhaps they should be squashed down
> before being applied.
>
> Cheers,
> Sam.
>
> Patch set changelog follows:
>
> ====== v1 -> v2: ======
>
> Patch 1/9: powerpc/eeh: Remove eeh_handle_event()
>
> Patch 2/9: powerpc/eeh: Manage EEH_PE_RECOVERING inside eeh_handle_normal_event()
>
> Patch 3/9: powerpc/eeh: Fix misleading comment in __eeh_addr_cache_get_device()
>
> Patch 4/9: powerpc/eeh: Remove misleading test in eeh_handle_normal_event()
>
> Patch 5/9: powerpc/eeh: Rename frozen_bus to bus in eeh_handle_normal_event()
>
> Patch 6/9: powerpc/eeh: Clarify arguments to eeh_reset_device()
> * Re-ordered parameters to eeh_reset_device() to keep pe first.
> * Changed eeh_aware_driver to driver_eeh_aware.
>
> Patch 7/9: powerpc/eeh: Remove always-true tests in eeh_reset_device()
>
> Patch 8/9: powerpc/eeh: Factor out common code eeh_reset_device()
> * In one case, added braces to "if" to match "else".
>
> Patch 9/9: powerpc/eeh: Add eeh_state_active() helper
>
> ====== v1: ======
>
> Patch 1/9: powerpc/eeh: Remove eeh_handle_event()
> Patch 2/9: powerpc/eeh: Manage EEH_PE_RECOVERING inside eeh_handle_normal_event()
> Patch 3/9: powerpc/eeh: Fix misleading comment in __eeh_addr_cache_get_device()
> Patch 4/9: powerpc/eeh: Remove misleading test in eeh_handle_normal_event()
> Patch 5/9: powerpc/eeh: Rename frozen_bus to bus in eeh_handle_normal_event()
> Patch 6/9: powerpc/eeh: Clarify arguments to eeh_reset_device()
> Patch 7/9: powerpc/eeh: Remove always-true tests in eeh_reset_device()
> Patch 8/9: powerpc/eeh: Factor out common code eeh_reset_device()
> Patch 9/9: powerpc/eeh: Add eeh_state_active() helper
>
> Sam Bobroff (9):
> powerpc/eeh: Remove eeh_handle_event()
> powerpc/eeh: Manage EEH_PE_RECOVERING inside eeh_handle_normal_event()
> powerpc/eeh: Fix misleading comment in __eeh_addr_cache_get_device()
> powerpc/eeh: Remove misleading test in eeh_handle_normal_event()
> powerpc/eeh: Rename frozen_bus to bus in eeh_handle_normal_event()
> powerpc/eeh: Clarify arguments to eeh_reset_device()
> powerpc/eeh: Remove always-true tests in eeh_reset_device()
> powerpc/eeh: Factor out common code eeh_reset_device()
> powerpc/eeh: Add eeh_state_active() helper
>
> arch/powerpc/include/asm/eeh.h | 6 ++
> arch/powerpc/include/asm/eeh_event.h | 3 +-
> arch/powerpc/kernel/eeh.c | 19 ++--
> arch/powerpc/kernel/eeh_cache.c | 3 +-
> arch/powerpc/kernel/eeh_driver.c | 137 +++++++++++----------------
> arch/powerpc/kernel/eeh_event.c | 6 +-
> arch/powerpc/platforms/powernv/eeh-powernv.c | 9 +-
> 7 files changed, 72 insertions(+), 111 deletions(-)
>
Nice cleanup,
Reviewed-by: Alexey Kardashevskiy <aik at ozlabs.ru>
--
Alexey
More information about the Linuxppc-dev
mailing list