[PATCH 0/9] EEH refactoring 1
Sam Bobroff
sam.bobroff at au1.ibm.com
Tue Mar 6 10:58:15 AEDT 2018
Hello everyone,
Here is a set of some small, mostly idempotent, changes to improve
maintainability in some of the EEH code, primarily in eeh_driver.c.
I've kept them all small to aid review but perhaps they should be squashed down
before being applied.
Cheers,
Sam.
Sam Bobroff (9):
powerpc/eeh: Remove eeh_handle_event()
powerpc/eeh: Manage EEH_PE_RECOVERING inside eeh_handle_normal_event()
powerpc/eeh: Fix misleading comment in __eeh_addr_cache_get_device()
powerpc/eeh: Remove misleading test in eeh_handle_normal_event()
powerpc/eeh: Rename frozen_bus to bus in eeh_handle_normal_event()
powerpc/eeh: Clarify arguments to eeh_reset_device()
powerpc/eeh: Remove always-true tests in eeh_reset_device()
powerpc/eeh: Factor out common code eeh_reset_device()
powerpc/eeh: Add eeh_state_active() helper
arch/powerpc/include/asm/eeh.h | 6 ++
arch/powerpc/include/asm/eeh_event.h | 3 +-
arch/powerpc/kernel/eeh.c | 19 ++--
arch/powerpc/kernel/eeh_cache.c | 3 +-
arch/powerpc/kernel/eeh_driver.c | 143 +++++++++++----------------
arch/powerpc/kernel/eeh_event.c | 6 +-
arch/powerpc/platforms/powernv/eeh-powernv.c | 9 +-
7 files changed, 75 insertions(+), 114 deletions(-)
--
2.16.1.74.g9b0b1f47b
More information about the Linuxppc-dev
mailing list