[PATCH 00/16] Finally remove PSERIES from exception naming
Nicholas Piggin
npiggin at gmail.com
Wed Aug 1 12:12:39 AEST 2018
On Thu, 26 Jul 2018 23:07:01 +1000
Michael Ellerman <mpe at ellerman.id.au> wrote:
> This finally annoyed me enough to do something about it, I foolishly started
> pulling the string and now here I am.
>
> I think the end result is sufficiently more readable to justify the churn. I
> particularly like that we now have EXCEPTION_PROLOG_0/1/2.
>
> It will cause some pain for backports, but Nick plans to rewrite the exception
> vectors entirely at some point so this will be trivial in comparison.
Yeah I have no problem with this series. I'll get onto that rewrite
again soon.
Acked-by: Nicholas Piggin <npiggin at gmail.com>
>
> cheers
>
>
> Michael Ellerman (16):
> powerpc/64s: Move SET_SCRATCH0() into EXCEPTION_PROLOG_PSERIES()
> powerpc/64s: Move SET_SCRATCH0() into EXCEPTION_RELON_PROLOG_PSERIES()
> powerpc/64s: Rename STD_EXCEPTION_PSERIES to STD_EXCEPTION
> powerpc/64s: Rename STD_EXCEPTION_PSERIES_OOL to STD_EXCEPTION_OOL
> powerpc/64s: Rename STD_RELON_EXCEPTION_PSERIES to STD_RELON_EXCEPTION
> powerpc/64s: Rename STD_RELON_EXCEPTION_PSERIES_OOL to
> STD_RELON_EXCEPTION_OOL
> powerpc/64s: Rename EXCEPTION_PROLOG_PSERIES_1 to EXCEPTION_PROLOG_2
> powerpc/64s: Remove PSERIES from the NORI macros
> powerpc/64s: Rename EXCEPTION_RELON_PROLOG_PSERIES_1
> powerpc/64s: Rename EXCEPTION_RELON_PROLOG_PSERIES
> powerpc/64s: Rename EXCEPTION_PROLOG_PSERIES to EXCEPTION_PROLOG
> powerpc/64s: Drop _MASKABLE_EXCEPTION_PSERIES()
> powerpc/64s: Drop _MASKABLE_RELON_EXCEPTION_PSERIES()
> powerpc/64s: Remove PSERIES naming from the MASKABLE macros
> powerpc/64s: Drop unused loc parameter to MASKABLE_EXCEPTION macros
> powerpc/64s: Don't use __MASKABLE_EXCEPTION unnecessarily
>
> arch/powerpc/include/asm/exception-64s.h | 117 ++++++++++++++-----------------
> arch/powerpc/include/asm/head-64.h | 16 ++---
> arch/powerpc/kernel/exceptions-64s.S | 32 ++++-----
> 3 files changed, 72 insertions(+), 93 deletions(-)
>
More information about the Linuxppc-dev
mailing list