[PATCH v6 12/12] powerpc: Rename soft_enabled to soft_disabled_mask

Nicholas Piggin npiggin at gmail.com
Tue Jan 10 17:02:06 AEDT 2017


On Mon,  9 Jan 2017 19:06:18 +0530
Madhavan Srinivasan <maddy at linux.vnet.ibm.com> wrote:

> Rename the paca->soft_enabled to paca->soft_disabled_mask as
> it is no more used as a flag for interrupt state.
> 
> Signed-off-by: Madhavan Srinivasan <maddy at linux.vnet.ibm.com>

Reviewed-by: Nicholas Piggin <npiggin at gmail.com>

> -static inline notrace void soft_enabled_set(unsigned long enable)
> +static inline notrace void soft_disabled_mask_set(unsigned long enable)

> -static inline notrace unsigned long soft_enabled_set_return(unsigned long enable)
> +static inline notrace unsigned long soft_disabled_mask_set_return(unsigned long enable)

> -static inline notrace unsigned long soft_enabled_or_return(unsigned long enable)
> +static inline notrace unsigned long soft_disabled_mask_or_return(unsigned long enable)

> @@ -228,11 +228,11 @@ notrace void arch_local_irq_restore(unsigned long en)
>  	unsigned int replay;
>  
>  #ifdef CONFIG_IRQ_DEBUG_SUPPORT
> -	WARN_ON(en & local_paca->soft_enabled & ~IRQ_DISABLE_MASK_LINUX);
> +	WARN_ON(en & local_paca->soft_disabled_mask & ~IRQ_DISABLE_MASK_LINUX);
>  #endif
>  
>  	/* Write the new soft-enabled value */
> -	soft_enabled_set(en);
> +	soft_disabled_mask_set(en);
>  

Aside from a few minor instances of variable names and comments, this
looks good to me. Much easier to read.

I have no remaining issues with this series.

Thanks,
Nick


More information about the Linuxppc-dev mailing list