[PATCH v6 00/12]powerpc: "paca->soft_enabled" based local atomic operation implementation

Madhavan Srinivasan maddy at linux.vnet.ibm.com
Wed Feb 15 20:36:47 AEDT 2017

On Wednesday 08 February 2017 06:14 PM, Michael Ellerman wrote:
> Madhavan Srinivasan <maddy at linux.vnet.ibm.com> writes:
>> Hi mpe,
>> Any update on this series. Have also fixed the naming issue with patch 12
>> and with this series applied,
>> "paca->soft_enabled"  becomes "paca->soft_disabled_mask"
> Yeah sorry I've been putting off dealing with it.
> Ideally we'd do the naming change earlier in the series, but maybe
> that's not worth it.
> The one thing I wanted to make sure was that regs->softe is never
> exposed to userspace. Because we're changing its semantics, and user
> space has no business knowing about it.
> So I just checked the code, and we do allow userspace to see the softe
> value. So I think we should fix that before this goes in.
> The safest option is to just hardwire it to 1, as that's the value it
> should always have in a userspace pt_regs.
Ok let me look at this, currently  I do see the "softe" used
to decide on the return_irq path and does not look straight
forward change.


> cheers

More information about the Linuxppc-dev mailing list