[PATCH 1/2] powerpc/powernv: Add config option for removal of memory

Anshuman Khandual khandual at linux.vnet.ibm.com
Fri Apr 28 19:39:09 AEST 2017


On 04/28/2017 11:12 AM, Rashmica Gupta wrote:
> Signed-off-by: Rashmica Gupta <rashmica.g at gmail.com>

Please describe a bit about the function/feature you are trying
to add with this new config option. The subject says " Add config
option for removal of memory" but I guess its not related to
memory hotplug but about hardware enabled tracing IIUC. Hence
it should have some amount of description.

> ---
>  arch/powerpc/platforms/powernv/Kconfig  | 4 ++++
>  arch/powerpc/platforms/powernv/Makefile | 1 +
>  2 files changed, 5 insertions(+)
> 
> diff --git a/arch/powerpc/platforms/powernv/Kconfig b/arch/powerpc/platforms/powernv/Kconfig
> index 6a6f4ef..1b8b3a8 100644
> --- a/arch/powerpc/platforms/powernv/Kconfig
> +++ b/arch/powerpc/platforms/powernv/Kconfig
> @@ -30,3 +30,7 @@ config OPAL_PRD
>  	help
>  	  This enables the opal-prd driver, a facility to run processor
>  	  recovery diagnostics on OpenPower machines
> +
> +config HARDWARE_TRACING

This is too generic for platform specific feature and also it does
not intend to fit into a generic HW tracing infrastructure. IMHO
it should be named something like "PPC64_HARDWARE_TRACING" or
something similar.

> +	bool 'Enable removal of memory for hardware memory tracing'

If this memory is going to be taken out of memblock like normal
memory hotplug and eventually goes away from kernel control, then
you need to be more specific about its usage.



More information about the Linuxppc-dev mailing list