[PATCH 2/3] powerpc: Load Monitor Register Support

Jack Miller jack at codezen.org
Thu Apr 14 03:39:50 AEST 2016


Thanks, yeah, that's more readable and more correct. I'll change it in
the next spin.

- Jack

On Tue, Apr 12, 2016 at 12:40 AM, Segher Boessenkool
<segher at kernel.crashing.org> wrote:
> Hi,
>
> On Mon, Apr 11, 2016 at 01:57:44PM -0500, Jack Miller wrote:
>>  __init_FSCR:
>>       mfspr   r3,SPRN_FSCR
>> +     andi.   r3,r3,(~FSCR_LM)@L
>>       ori     r3,r3,FSCR_TAR|FSCR_DSCR|FSCR_EBB
>>       mtspr   SPRN_FSCR,r3
>>       blr
>
> This clears the top 48 bits as well.  Shouldn't matter currently; but
> more robust (and easier to read, if you know the idiom) is
>
>         ori     r3,r3,FSCR_LM|FSCR_TAR|FSCR_DSCR|FSCR_EBB
>         xori    r3,r3,FSCR_LM
>
>
> Segher


More information about the Linuxppc-dev mailing list