[V2] powerpc/signal: Add helper function to fetch quad word aligned pointer

Anshuman Khandual khandual at linux.vnet.ibm.com
Tue Jul 21 15:04:08 AEST 2015


On 07/21/2015 07:07 AM, Michael Ellerman wrote:
> On Mon, 2015-20-07 at 02:58:43 UTC, Anshuman Khandual wrote:
>> This patch adds one helper function 'sigcontext_vmx_regs' which computes
>> quad word aligned pointer for 'vmx_reserve' array element in sigcontext
>> structure making the code more readable.
>>
>> diff --git a/arch/powerpc/kernel/signal_64.c b/arch/powerpc/kernel/signal_64.c
>> index c7c24d2..bb9c939 100644
>> --- a/arch/powerpc/kernel/signal_64.c
>> +++ b/arch/powerpc/kernel/signal_64.c
>> @@ -74,6 +74,16 @@ static const char fmt64[] = KERN_INFO \
>>  	"%s[%d]: bad frame in %s: %016lx nip %016lx lr %016lx\n";
>>  
>>  /*
>> + * This computes quad word aligned pointer for 'vmx_reserve' array element
>> + * which is used primarily in assigning to the preceding pointer 'v_regs'
>> + * in sigcontext structure.
> 
> How about:
> 
>   * This computes a quad word aligned pointer inside the vmx_reserve array
>   * element. For historical reasons sigcontext might not be quad word aligned,
>   * but the location we write the VMX regs to must be. See the comment in
>   * sigcontext for more detail.

Yeah, its way better. Thanks !

> 
> 
>> + */
>> +static elf_vrreg_t __user *sigcontext_vmx_regs(struct sigcontext __user *sc)
>> +{
>> +	return (elf_vrreg_t __user *) (((unsigned long)sc->vmx_reserve + 15) & ~0xful);
>> +}
> 
> This doesn't build for ppc64e_defconfig:

This time, I did build test for some of the configs but not the entire
comprehensive list. Sorry, missed this one though, will take care next
time around.

> 
>   arch/powerpc/kernel/signal_64.c:82:28: error: 'sigcontext_vmx_regs' defined but not used [-Werror=unused-function]
>    static elf_vrreg_t __user *sigcontext_vmx_regs(struct sigcontext __user *sc)
>                             ^
> 
> For now I'll just #ifdef it.
> 
> Please do a test build of ppc64e_defconfig in future.



More information about the Linuxppc-dev mailing list