[4/8] powerpc/slb: Add some helper functions to improve modularization

Michael Ellerman mpe at ellerman.id.au
Wed Aug 12 14:11:17 AEST 2015


On Wed, 2015-29-07 at 07:10:01 UTC, Anshuman Khandual wrote:
> This patch adds the following six helper functions to help improve
> modularization and readability of the code.
> 
> (1) slb_invalidate_all:		Invalidates the entire SLB
> (2) slb_invalidate:		Invalidates SLB entries present in PACA
> (3) mmu_linear_vsid_flags:	VSID flags for kernel linear mapping
> (4) mmu_virtual_vsid_flags:	VSID flags for kernel virtual mapping
> (5) mmu_vmemmap_vsid_flags:	VSID flags for kernel vmem mapping
> (6) mmu_io_vsid_flags:		VSID flags for kernel I/O mapping

That's too many changes for one patch, it's certainly not a single logical change.

I'm happy with all the flag ones being done in a single patch, but please do
the other two in separate patches.

cheers


More information about the Linuxppc-dev mailing list