[PATCH 3/3] KVM: PPC: BOOK3S: HV: Rename variable for better readability

Paul Mackerras paulus at samba.org
Thu Nov 27 11:45:26 AEDT 2014


On Mon, Oct 20, 2014 at 07:59:00PM +0530, Aneesh Kumar K.V wrote:
> Minor cleanup
> 
> Signed-off-by: Aneesh Kumar K.V <aneesh.kumar at linux.vnet.ibm.com>
> ---
>  arch/powerpc/kvm/book3s_hv_rm_mmu.c | 25 +++++++++++++------------
>  1 file changed, 13 insertions(+), 12 deletions(-)
> 
> diff --git a/arch/powerpc/kvm/book3s_hv_rm_mmu.c b/arch/powerpc/kvm/book3s_hv_rm_mmu.c
> index 78e689b066f1..2922f8d127ff 100644
> --- a/arch/powerpc/kvm/book3s_hv_rm_mmu.c
> +++ b/arch/powerpc/kvm/book3s_hv_rm_mmu.c
> @@ -523,7 +523,7 @@ long kvmppc_h_bulk_remove(struct kvm_vcpu *vcpu)
>  	unsigned long *args = &vcpu->arch.gpr[4];
>  	__be64 *hp, *hptes[4];
>  	unsigned long tlbrb[4];
> -	long int i, j, k, n, found, indexes[4];
> +	long int i, j, k, collected_hpte, found, indexes[4];

Hmmm... I don't find it more readable, because "collected_hpte" sounds
like it contains a HPTE value.  Also I don't like using a long name
for something that is just a temporary value inside a function, and
"n" is a suitable name for a temporary variable counting the number of
things we have.  I would prefer just adding a comment like this:

-		n = 0;
+		n = 0;	/* # values collected in tlbrb[], indexes[] etc. */

Paul.


More information about the Linuxppc-dev mailing list