[PATCH 2/2] powerpc/nohash: Split __early_init_mmu() into boot and secondary
Scott Wood
scottwood at freescale.com
Wed Aug 6 10:48:10 EST 2014
On Tue, 2014-08-05 at 14:36 +1000, Benjamin Herrenschmidt wrote:
> On Fri, 2014-08-01 at 22:07 -0500, Scott Wood wrote:
>
> >
> > -void __init early_init_mmu(void)
> > -{
> > - __early_init_mmu(1);
> > -}
> > -
> > void early_init_mmu_secondary(void)
> > {
> > - __early_init_mmu(0);
> > + early_init_mmu_allcpus();
> > }
>
> Small nit, it took me 30s too long to figure out what you were doing due
> to the naming above :)
>
> Call the latter early_init_this_mmu() and keep the global one separate
> such that early_init_mmu() does:
>
> early_init_mmu_common();
> early_init_this_mmu();
I'll do s/mmu_allcpus/this_mmu/ but early_init_mmu() needs to do things
both before and after early_init_mmu_common(). Do you want two new
functions (before and after) or is it OK to just rename
early_init_mmu_allcpus() and put a comment before early_init_mmu()
saying it's just for the boot cpu?
-Scott
More information about the Linuxppc-dev
mailing list