[RFC PATCH 08/11] kvm: powerpc: book3s: Support building HV and PR KVM as module

Alexander Graf agraf at suse.de
Mon Sep 30 20:04:02 EST 2013


On 27.09.2013, at 15:08, Aneesh Kumar K.V wrote:

> Alexander Graf <agraf at suse.de> writes:
> 
>> On 27.09.2013, at 12:03, Aneesh Kumar K.V wrote:
>> 
>>> diff --git a/arch/powerpc/kvm/book3s_64_mmu_host.c b/arch/powerpc/kvm/book3s_64_mmu_host.c
>>> index fd5b393..775d368 100644
>>> --- a/arch/powerpc/kvm/book3s_64_mmu_host.c
>>> +++ b/arch/powerpc/kvm/book3s_64_mmu_host.c
>>> @@ -27,6 +27,7 @@
>>> #include <asm/machdep.h>
>>> #include <asm/mmu_context.h>
>>> #include <asm/hw_irq.h>
>>> +
>> 
>> Stray whitespace change
>> 
> 
> will fix
> 
>>> #include "trace_pr.h"
>>> 
>>> #define PTE_SIZE 12
>>> diff --git a/arch/powerpc/kvm/book3s_emulate.c b/arch/powerpc/kvm/book3s_emulate.c
>>> index b9841ad..20d03c2 100644
>>> --- a/arch/powerpc/kvm/book3s_emulate.c
>>> +++ b/arch/powerpc/kvm/book3s_emulate.c
>>> @@ -172,7 +172,7 @@ int kvmppc_core_emulate_op_pr(struct kvm_run *run, struct kvm_vcpu *vcpu,
>>> 			vcpu->arch.mmu.tlbie(vcpu, addr, large);
>>> 			break;
>>> 		}
>>> -#ifdef CONFIG_KVM_BOOK3S_64_PR
>>> +#ifdef CONFIG_KVM_BOOK3S_PR
>> 
>> Why?
> 
> If i have CONFIG_KVM_BOOK3S_64_PR=m  #ifdef CONFIG_KVM_BOOK3S_64_PR will
> not work. There is a runtime check I can use IS_ENABLED(). But didn't
> want to do those. Hence moved to the symbol which will be set as
> CONFIG_KVM_BOOK3S_PR = y

Ah, I see. The naming starts to get really confusing. Could you please give this a slightly better name, such as CONFIG_KVM_BOOK3S_PR_POSSIBLE or such, so that it's obvious that this #ifdef doesn't mean "option is enabled", but instead means "option can potentially be enabled through a module".


Alex



More information about the Linuxppc-dev mailing list