On 29 March 2013 10:17, Tang Yuantian-B29983 <B29983 at freescale.com> wrote: > I thought it was OK here. Apparently, sizeof(*table) is better. > But kcalloc is OK. Yes yes, Kcalloc is okay... I have misread that part earlier when i suggested kzalloc. In last mail i was referring to sizeof() only.