[alsa-devel] [PATCH v4 1/2] ASoC: fsl: Add S/PDIF CPU DAI driver

Fabio Estevam festevam at gmail.com
Wed Aug 14 03:58:26 EST 2013


On Mon, Aug 12, 2013 at 9:01 AM, Nicolin Chen <b42378 at freescale.com> wrote:
> +Required properties:
> +
> +  - compatible : Compatible list, contains "fsl,<chip>-spdif". Using general

Can't we just use "fsl,fsl-spdif" instead?

> +  "fsl,fsl-spdif" will get the default SoC type -- imx6q-spdif.
> +

I think this is not the usual approach we do with dt.

> +static const struct of_device_id fsl_spdif_dt_ids[] = {
> +       { .compatible = "fsl,fsl-spdif", },

Isn't only the first entry enough here?

> +       { .compatible = "fsl,imx6q-spdif", },
> +       { .compatible = "fsl,imx6sl-spdif", },
> +       { .compatible = "fsl,imx53-spdif", },
> +       {}
> +};
> +MODULE_DEVICE_TABLE(of, fsl_spdif_dt_ids);
> +
> +static struct platform_driver fsl_spdif_driver = {
> +       .driver = {
> +               .name = "fsl-spdif-dai",
> +               .owner = THIS_MODULE,
> +               .of_match_table = fsl_spdif_dt_ids,
> +       },
> +       .probe = fsl_spdif_probe,
> +       .remove = fsl_spdif_remove,
> +};
> +
> +module_platform_driver(fsl_spdif_driver);
> +
> +MODULE_AUTHOR("Freescale Semiconductor, Inc.");
> +MODULE_DESCRIPTION("Freescale S/PDIF CPU DAI Driver");
> +MODULE_LICENSE("GPL v2");
> +MODULE_ALIAS("platform:fsl_spdif");

This MODULE_ALIAS name does not match the name you provided earlier:

.name = "fsl-spdif-dai"


More information about the Linuxppc-dev mailing list