[PATCH v2 2/7] dt/powerpc: Use of_get_child_by_name to get a named child.

Rob Herring robherring2 at gmail.com
Fri Sep 14 23:06:52 EST 2012


On 09/14/2012 03:18 AM, Srinivas KANDAGATLA wrote:
> From: Srinivas Kandagatla <srinivas.kandagatla at st.com>
> 
> As follow-up to "dt: introduce of_get_child_by_name to get child node by
> name." patch, This patch removes some of the code duplication in the
> driver by replacing it with of_get_child_by_name instead.
> 
> Signed-off-by: Srinivas Kandagatla <srinivas.kandagatla at st.com>
> ---
>  arch/powerpc/kernel/prom.c |    5 +----
>  1 files changed, 1 insertions(+), 4 deletions(-)
> 
> diff --git a/arch/powerpc/kernel/prom.c b/arch/powerpc/kernel/prom.c
> index f191bf0..80e5b6c 100644
> --- a/arch/powerpc/kernel/prom.c
> +++ b/arch/powerpc/kernel/prom.c
> @@ -735,7 +735,6 @@ void __init early_init_devtree(void *params)
>   */
>  struct device_node *of_find_next_cache_node(struct device_node *np)
>  {
> -	struct device_node *child;
>  	const phandle *handle;
>  
>  	handle = of_get_property(np, "l2-cache", NULL);
> @@ -749,9 +748,7 @@ struct device_node *of_find_next_cache_node(struct device_node *np)
>  	 * beneath CPU nodes.
>  	 */
>  	if (!strcmp(np->type, "cpu"))
> -		for_each_child_of_node(np, child)
> -			if (!strcmp(child->type, "cache"))

name and type are not the same thing.

Rob

> -				return child;
> +		return of_get_child_by_name(np, "cache");
>  
>  	return NULL;
>  }
> 



More information about the Linuxppc-dev mailing list