Help initialize phy-less ethernet in 2.6.38

Fabio pozzi.fabio at
Fri Mar 30 06:56:15 EST 2012

> Which old kernel driver?  Why do you need to mess with fs_platform_info?
I have to port a custom platform driver written for 2.6.10 to support
this custom board.
That driver directly initializes the fs_platform_info data structure,
so after some failed attempts I thought to directly assign some values
to the fs_platform_info structure to see reuse part of the old code,
just to get the device to work.

> Why do you think the interrupt is misconfigured?
Because I don't get any error during boot or when I run ifconfig, but
I don't see
any interrupt if I run 'cat /proc/interrupts':
 16:        136   CPM2 SIU         Level        cpm_uart
 32:          0   CPM2 SIU         Level        fs_enet-mac
LOC:       1219   Local timer interrupts
SPU:          0   Spurious interrupts
CNT:          0   Performance monitoring interrupts
MCE:          0   Machine check exceptions

>Looking at the code, though, I'm not sure if this stuff still works --
>e.g. I don't see where any fields of fixed-link but the ID are used, or
>what's supposed to happen when of_phy_connect_fixed_link() calls
If it isn't so, do you have any suggestion about how to re-add this
functionality to the existing code?

I will make some other tests taking as an example the mgcoge.dts which
seems the most similar to my custom board.

Thanks in advance,

Fabio Pozzi

More information about the Linuxppc-dev mailing list