[RFC PATCH 1/12] memory-hotplug : rename remove_memory to offline_memory
wency at cn.fujitsu.com
Thu Jun 28 13:25:16 EST 2012
At 06/28/2012 11:01 AM, Yasuaki Ishimatsu Wrote:
> Hi David and Wen,
> Thank you for reviewing my patch.
> 2012/06/27 17:47, Wen Congyang wrote:
>> At 06/27/2012 03:14 PM, Wen Congyang Wrote:
>>> At 06/27/2012 01:42 PM, Yasuaki Ishimatsu Wrote:
>>>> remove_memory() does not remove memory but just offlines memory. The patch
>>>> changes name of it to offline_memory().
>>> There are 3 functions in the kernel:
>>> 1. add_memory()
>>> 2. online_pages()
>>> 3. remove_memory()
>>> So I think offline_pages() is better than offline_memory().
>> There is already a function named offline_pages(). So we
>> should call offline_pages() instead of remove_memory() in
>> memory_block_action(), and there is no need to rename
> As Wen says, Linux has 4 functions for memory hotplug already.
> In my recognition, these functions are prepared for following purpose.
> 1. add_memory : add physical memory
> 2. online_pages : online logical memory
> 3. remove_memory : offline logical memory
> 4. offline_pages : offline logical memory
> add_memory() is used for adding physical memory. I think remove_memory()
> would rather be used for removing physical memory than be used for removing
> logical memory. So I renamed remove_memory() to offline_memory().
> How do you think?
Hmm, remove_memory() will revert all things we do in add_memory(), so I think
there is no need to rename it. If we rename it to offline_memory(), we should
also rename add_memory() to online_memory().
> Yasuaki Ishimatsu
>> Wen Congyang
>>> Wen Congyang
More information about the Linuxppc-dev