[RFC PATCH 1/12] memory-hotplug : rename remove_memory to offline_memory

David Rientjes rientjes at google.com
Wed Jun 27 16:10:32 EST 2012

On Wed, 27 Jun 2012, Yasuaki Ishimatsu wrote:

> remove_memory() does not remove memory but just offlines memory. The patch
> changes name of it to offline_memory().

The kernel is never going to physically remove the memory itself, so I 
don't see the big problem with calling it remove_memory().  If you're 
going to change it to offline_memory(), which is just as good but not 
better, then I'd suggest changing add_memory() to online_memory() for 

More information about the Linuxppc-dev mailing list