Sridhar Addagada sridhar_a at
Tue Jan 24 16:34:10 EST 2012

I have a hang problem on my board based on MPC8377EWLAN, here is how i ran into problem. We are using u-boot to load the kernel, rootfs and device tree.  The kernel parameters have been set 

root=/dev/ram rw rootfstype=ext2 ramdisk_size=131322 console=ttyS0,115200

but I load the rootfs image generated of rootfs.jffs2 (we use buildroot), which results in kernel spitting the following message and hang.  I even enabled the WDT (mpc83xx_wdt.c) the board does not get reset.

Any ideas would be appreciated.


TCP cubic registered
Initializing XFRM netlink socket
NET: Registered protocol family 17
NET: Registered protocol family 15
8021q: 802.1Q VLAN Support v1.8
lib80211: common routines for IEEE802.11 drivers
Registering the dns_resolver key type
rtc-m41t80 0-0068: setting system clock to 2012-01-23 20:32:26 UTC (1327350746)
RAMDISK: Couldn't find valid RAM disk image starting at 0.
List of all partitions:
1f00             512 mtdblock0  (driver?)
1f01             128 mtdblock1  (driver?)
1f02            5120 mtdblock2  (driver?)
1f03           10240 mtdblock3  (driver?)
1f04             128 mtdblock4  (driver?)
1f05            5120 mtdblock5  (driver?)
1f06           10240 mtdblock6  (driver?)
1f07             128 mtdblock7  (driver?)
1f08             128 mtdblock8  (driver?)
1f09           99328 mtdblock9  (driver?)
No filesystem could mount root, tried:  ext2 squashfs
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)
Call Trace:
[cf82bef0] [c0007fa0] show_stack+0x4c/0x144 (unreliable)
[cf82bf30] [c02e8074] panic+0xac/0x1f8
[cf82bf80] [c03c3df0] mount_block_root+0x288/0x2ac
[cf82bfc0] [c03c401c] prepare_namespace+0x1a0/0x1ec
[cf82bfe0] [c03c3248] kernel_init+0x114/0x130
[cf82bff0] [c000d768] kernel_thread+0x4c/0x68
Rebooting in 180 seconds..
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Linuxppc-dev mailing list