[PATCH 5/6] powerpc: Macros for saving/restore PPR
michael at ellerman.id.au
Tue Dec 11 13:41:11 EST 2012
On Mon, 2012-11-26 at 17:49 -0800, Haren Myneni wrote:
> On 11/22/2012 07:39 PM, Michael Neuling wrote:
> > Haren Myneni <haren at linux.vnet.ibm.com> wrote:
> >> [PATCH 5/6] powerpc: Macros for saving/restore PPR
> > Maybe we should change the names
> > HTM_MEDIUM_NO_PPR => HTM_MEDIUM_PPR_DISCARD and
> > HTM_MEDIUM_HAS_PPR => HTM_MEDIUM_PPR_SAVE
> > But now I'm heading into bike shedding territory... plus I think I
> > suggested the names you have currently, so I'm feeling a bit dumb now
> > :-)
> No problem, We can change these macro names if HTM_MEDIUM_PPR_DISCARD/
> HTM_MEDIUM_PPR_SAVE gives better description.
Yes, those names are better.
Even though they're macros they act as functions, so they should
preferably be named using a verb.
More information about the Linuxppc-dev