[PATCH 11/13] kvm/powerpc: Handle some PAPR hcalls in the kernel
Paul Mackerras
paulus at samba.org
Tue May 17 20:28:40 EST 2011
On Tue, May 17, 2011 at 09:54:35AM +0200, Alexander Graf wrote:
> Not sure I like the name - when is it used? :)
When the real-mode hcall handler decides it can't handle the hcall and
wants to pass it up.
> Also, if it's not in the PAPR, the guest should never receive it, right?
Right. It's purely an internal value.
> > + /* See if this is something we can handle in real mode */
> > + cmpwi r12,0xc00
>
> use the define please
OK
> > + beq hcall_real_mode
>
> This is simply a hcall helper, as the name suggests. So the comment
> is slightly misleading - it should rather read like "Try to handle
> hypercalls in real mode".
Hmmm, OK, that's what it was trying to indicate. I could add "try" to
the name if you like.
> > + cmpdi r3,H_TOO_HARD
> > + beq hcall_real_fallback
>
> Ah, very good. Please mark the constant as "for internal use only"
> then, as that's certainly fine :).
Cool, will do.
> > + li r12,0xc00
>
> use the define please :)
OK.
Thanks,
Paul.
More information about the Linuxppc-dev
mailing list