[PATCH] Add support for PowerMac3,5 in snd-aoa ALSA sound module

Linux User #330250 linuxuser330250 at gmx.net
Thu Feb 24 04:56:22 EST 2011

----------  Original message  ----------
Subject: Re: [PATCH] Add support for PowerMac3,5 in snd-aoa ALSA sound module
Date:    Montag, 21. Februar 2011N
From:    Benjamin Herrenschmidt <benh at kernel.crashing.org>
To:      Takashi Iwai <tiwai at suse.de>

> So somebody else can just pick the "documentation" that layout ID 21
> works just like 22 for us, and write an "acceptable" patch... 

Actually, the G4 "Quicksilver" PowerMac3,5 is propably more alike to the G4 
"Digital Audio" PowerMac3,4 in this regard. The device ID on the Digital Audio 
is decimal 14. The Quicksilver is decimal 21.

PowerMac3,4 Digital Audio: Device ID 14, ??? chip
PowerMac3,5 Quicksilver: Device ID 21, TAS 3001C CODEC chip
PowerMac3,6 Mirrored Drive Doors: Device ID 22, TAS3004 CODEC chip

$LINUX/sound/aoa/codecs/tas.c driver was originally made for the TAS3004, 
which I figure because only "tas 3004" is mentioned in the source, no other.

Since the Quicksilver, which is newer than the Digital Audio, doesn't have the 
TAS3004 chip (Mac OS X System Profiler states "Texas Intruments TAS3001C"), but 
the Digital Audio seemed to work fine with the aoa-tas codec too (it's already 
in the kernel) I tried it with the Quicksilver as well.

The modules loads without errors, the sound card is listed 
(/proc/asound/cards) and the volume controls are usable.

I played some sound and everything seemed to work fine. So I submitted the 

So now I have to appologize. And I'm glad the patch hasn't been accepted. Why?
Because I had booted with the wrong kernel when I tested if the sound played 
okay. I must have still used the powermac sound module, not aoa.


I tested again yesterday and today and can't get it to play a sound. I also 
checked the logs and all the ALSA stuff (in /proc/asound). Everything seems 
okay. I then tried a different mixer: pavucontrol -- because I have trouble to 
unmute without this on my PC too.

Now the surprise: it won't let me unmute.
Maybe it's just my system. I use Gentoo Linux and just recently updated the 
whole system to use Pulse Audio.

If anyone else could try the patch or write a new one on their G4 Quicksilvers 
I'd be happy.

And: I do understand the sign-off limiting to real names. It's a good thing.

Andreas  aka  Mac User #330250

More information about the Linuxppc-dev mailing list