[PATCH v2 1/6] spi/mpc8xxx: refactor the common code for SPI/eSPI controller
Hu Mingkai-B21284
B21284 at freescale.com
Thu Sep 2 18:27:38 EST 2010
Hi Grant and all,
Sorry for the delay, I'm on business trip some weeks ago.
> -----Original Message-----
> From: glikely at secretlab.ca [mailto:glikely at secretlab.ca] On Behalf Of Grant
> Likely
> Sent: Tuesday, August 10, 2010 2:40 PM
> To: Hu Mingkai-B21284
> Cc: linuxppc-dev at ozlabs.org; spi-devel-general at lists.sourceforge.net; Gala
> Kumar-B11780; Zang Roy-R61911
> Subject: Re: [PATCH v2 1/6] spi/mpc8xxx: refactor the common code for SPI/eSPI
> controller
>
> On Mon, Aug 2, 2010 at 1:51 AM, Mingkai Hu <Mingkai.hu at freescale.com> wrote:
> > Refactor the common code in file spi_mpc8xxx.c to spi_fsl_lib.c used
> > by SPI/eSPI controller driver as a library, move the SPI controller
> > driver to a new file spi_fsl_spi.c, and leave the QE/CPM SPI
> > controller code in this file.
> >
> > Because the register map of the SPI controller and eSPI controller is
> > so different, also leave the code operated the register to the driver
> > code, not the common code.
> >
> > Signed-off-by: Mingkai Hu <Mingkai.hu at freescale.com>
> > ---
> > v2:
> > - Rename spi_mpc8xxx.c to spi_fsl_lib.c, also the config name
> > - Rename fsl_spi.c to spi_fsl_spi.c, also the config name
> > - Move register map definiton from spi_fsl_lib.c to spi_fsl_spi.c
> > - Break some funcions line in the arguments instead of the
> > declaration
> > - Init bits_per_word to 0 to eliminate the else clause
> > - Add brace for the else clause to match if clause
> > - Drop the last entry's comma in the match table
> > - move module_init() immediately after the init fsl_spi_init()
> > function
> >
> > drivers/spi/Kconfig | 20 +-
> > drivers/spi/Makefile | 3 +-
> > drivers/spi/spi_fsl_lib.c | 237 ++++++++
> > drivers/spi/spi_fsl_lib.h | 119 ++++
> > drivers/spi/spi_fsl_spi.c | 1173
> > +++++++++++++++++++++++++++++++++++++
> > drivers/spi/spi_mpc8xxx.c | 1421
> > ---------------------------------------------
>
> This patch seems pretty good now. However, the rename from spi_mpc8xxx.c to
> spi_fsl_lib.c should be done in a separate patch. It is too difficult to track
> what has changed, when the file gets moved at the same time. Move the file in
> one patch verbatim (with the required Makefile change), and then move out the
> fsl_spi specific bits in a second patch.
>
Ok, I'll spilt this patch.
Thanks,
Mingkai
More information about the Linuxppc-dev
mailing list