[PATCH 7/9] v3 Define memory_block_size_bytes for powerpc/pseries

Nathan Fontenot nfont at austin.ibm.com
Tue Oct 5 01:45:14 EST 2010

On 10/03/2010 01:27 PM, Balbir Singh wrote:
> * Dave Hansen <dave at linux.vnet.ibm.com> [2010-10-03 11:11:01]:
>> On Sun, 2010-10-03 at 13:07 -0500, Robin Holt wrote:
>>> On Sun, Oct 03, 2010 at 11:25:00PM +0530, Balbir Singh wrote:
>>>> * Nathan Fontenot <nfont at austin.ibm.com> [2010-10-01 13:35:54]:
>>>>> Define a version of memory_block_size_bytes() for powerpc/pseries such that
>>>>> a memory block spans an entire lmb.
>>>> I hope I am not missing anything obvious, but why not just call it
>>>> lmb_size, why do we need memblock_size?
>>>> Is lmb_size == memblock_size after your changes true for all
>>>> platforms?
>>> What is an lmb?  I don't recall anything like lmb being referred to in
>>> the rest of the kernel.
>> Heh.  It's the OpenFirmware name for a Logical Memory Block.  Basically
>> what we use to determine the SECTION_SIZE on powerpc.  Probably not the
>> best terminology to use elsewhere in the kernel.
> Agreed for the kernel, this patch was for powerpc/pseries, hence was
> checking in this context.

I don't really see a reason to name it lmb_size, it seems easier
to stick with the naming used by the rest of the kernel.


More information about the Linuxppc-dev mailing list