[PATCH 1/4] irq: rename IRQF_TIMER to IRQF_NO_SUSPEND
Ian.Campbell at eu.citrix.com
Thu Jul 29 19:03:34 EST 2010
On Thu, 2010-07-29 at 09:49 +0100, Thomas Gleixner wrote:
> On Wed, 28 Jul 2010, Ian Campbell wrote:
> > Continue to provide IRQF_TIMER as an alias to IRQF_NO_SUSPEND since I
> > think it is worth preserving the nice self-documenting name (where it
> > is used appropriately). It also avoid needing to patch all the many
> > users who are using the flag for an actual timer interrupt.
> I'm not happy about the alias. What about:
> #define __IRQF_TIMER 0x00000200
> #define IRQF_NO_SUSPEND 0x00000400
> #define IRQF_TIMER (__IRQF_TIMER | IRQF_NO_SUSPEND)
Sure, I'll rework along those lines.
More information about the Linuxppc-dev